Vulnerability · Published Aug 20, 2026 · Assigned by GitHub_M

CVE-2026-63388Libevent: Heap out-of-bounds write in bufferevent_socket_set_conn_address_ reachable via AF_UNIX accept

High 8.4

In plain English

A high-severity out-of-bounds write in libevent from libevent. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.1% (higher than 4% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.4High
Exploit odds (30 days)0.1%top 96.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Libevent is an event notification library. Prior to 2.1.13 and 2.2.2-alpha, libevent has a heap out-of-bounds write in bufferevent_sock.c when bufferevent_socket_set_conn_address_ copies a kernel-supplied AF_UNIX peer address into bufferevent_private.conn_address. Release builds compiled with NDEBUG disable the EVUTIL_ASSERT length guard, and the evhttp accept path can pass a 110-byte sockaddr from accept() into the 28-byte field. An unauthenticated local peer able to connect to an AF_UNIX listener can overwrite the adjacent dns_request pointer and heap data, causing memory corruption with confidentiality, integrity, and availability impact. This issue is fixed in versions 2.1.13 and 2.2.2-alpha.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:10libevent2.1.13-1.el10_2ALSA-2026:67909
AlmaLinux:8libevent2.1.8-11.el8_10ALSA-2026:67908
AlmaLinux:9libevent2.1.13-1.el9_8ALSA-2026:67910
AlmaLinux:10libevent-devel2.1.13-1.el10_2ALSA-2026:67909
AlmaLinux:8libevent-devel2.1.8-11.el8_10ALSA-2026:67908
AlmaLinux:9libevent-devel2.1.13-1.el9_8ALSA-2026:67910
AlmaLinux:10libevent-doc2.1.13-1.el10_2ALSA-2026:67909
AlmaLinux:8libevent-doc2.1.8-11.el8_10ALSA-2026:67908
AlmaLinux:9libevent-doc2.1.13-1.el9_8ALSA-2026:67910
Debian:12libevent2.1.12-stable-8+deb12u1DEBIAN-CVE-2026-63388
Debian:13libevent2.1.13-stable-1~deb13u1DEBIAN-CVE-2026-63388
Debian:14libevent2.1.13-stable-1DEBIAN-CVE-2026-63388
Rocky Linux:10libevent0:2.1.13-1.el10_2RLSA-2026:67909
Rocky Linux:8libevent0:2.1.8-11.el8_10RLSA-2026:67908
Rocky Linux:9libevent0:2.1.13-1.el9_8RLSA-2026:67910
Ubuntu:22.04:LTSlibevent2.1.12-stable-1ubuntu0.2UBUNTU-CVE-2026-63388
Ubuntu:22.04:LTSlibevent2.1.12-stable-1ubuntu0.2USN-8840-1
Ubuntu:24.04:LTSlibevent2.1.12-stable-9ubuntu2.2USN-8840-1
Ubuntu:24.04:LTSlibevent2.1.12-stable-9ubuntu2.2UBUNTU-CVE-2026-63388
Ubuntu:26.04:LTSlibevent2.1.12-stable-10ubuntu0.2USN-8840-1
Ubuntu:26.04:LTSlibevent2.1.12-stable-10ubuntu0.2UBUNTU-CVE-2026-63388

Affected products (as reported)

VendorProductVersions
libevent libevent < 2.1.13>= 2.2.0-alpha, < 2.2.2-alpha

Weakness: CWE-617, CWE-787 · Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

References