Vulnerability · Published Aug 20, 2026 · Assigned by GitHub_M

CVE-2026-63385Libevent: HTTP header handling bugs create risk of access control bypass.

Critical 9.2

In plain English

A critical-severity security flaw in libevent from libevent. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.3% (higher than 70% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)9.2Critical
Exploit odds (30 days)1.3%top 29.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Libevent is an event notification library. Prior to 2.1.13 and 2.2.2-alpha, libevent has two HTTP parsing weaknesses in http.c. evhttp_decode_uri_internal decodes percent-encoded %00 bytes into literal NUL characters, which can cause downstream C string operations to truncate a path and bypass validation performed on a different representation. evhttp_header_is_valid_value also accepts obsolete line folding in header values containing carriage return or line feed characters, allowing a proxy and libevent to interpret headers differently and enabling header injection or access control bypass. The CRLF header acceptance is fixed in versions 2.1.13 and 2.2.2-alpha, but the reviewed patches do not clearly remediate the URI NUL-truncation condition.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:10libevent2.1.13-1.el10_2ALSA-2026:67909
AlmaLinux:8libevent2.1.8-11.el8_10ALSA-2026:67908
AlmaLinux:9libevent2.1.13-1.el9_8ALSA-2026:67910
AlmaLinux:10libevent-devel2.1.13-1.el10_2ALSA-2026:67909
AlmaLinux:8libevent-devel2.1.8-11.el8_10ALSA-2026:67908
AlmaLinux:9libevent-devel2.1.13-1.el9_8ALSA-2026:67910
AlmaLinux:10libevent-doc2.1.13-1.el10_2ALSA-2026:67909
AlmaLinux:8libevent-doc2.1.8-11.el8_10ALSA-2026:67908
AlmaLinux:9libevent-doc2.1.13-1.el9_8ALSA-2026:67910
Debian:12libevent2.1.12-stable-8+deb12u1DEBIAN-CVE-2026-63385
Debian:13libevent2.1.13-stable-1~deb13u1DEBIAN-CVE-2026-63385
Debian:14libevent2.1.13-stable-1DEBIAN-CVE-2026-63385
Rocky Linux:10libevent0:2.1.13-1.el10_2RLSA-2026:67909
Rocky Linux:8libevent0:2.1.8-11.el8_10RLSA-2026:67908
Rocky Linux:9libevent0:2.1.13-1.el9_8RLSA-2026:67910
Ubuntu:22.04:LTSlibevent2.1.12-stable-1ubuntu0.1UBUNTU-CVE-2026-63385
Ubuntu:22.04:LTSlibevent2.1.12-stable-1ubuntu0.1USN-8710-1
Ubuntu:24.04:LTSlibevent2.1.12-stable-9ubuntu2.1USN-8710-1
Ubuntu:24.04:LTSlibevent2.1.12-stable-9ubuntu2.1UBUNTU-CVE-2026-63385
Ubuntu:26.04:LTSlibevent2.1.12-stable-10ubuntu0.1USN-8710-1
Ubuntu:26.04:LTSlibevent2.1.12-stable-10ubuntu0.1UBUNTU-CVE-2026-63385

Affected products (as reported)

VendorProductVersions
libevent libevent >= 2.2.0-alpha, < 2.2.2-alpha< 2.1.13

Weakness: CWE-444 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:L/SC:L/SI:L/SA:N

References