Vulnerability · Published Aug 20, 2026 · Assigned by GitHub_M

CVE-2026-63384Libevent: `evtag_unmarshal_header()` decodes a wire `uint32` length into a signed `int` return value.

High 8.7

In plain English

A high-severity integer overflow in libevent from libevent. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 45% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.7High
Exploit odds (30 days)0.5%top 55.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

Libevent is an event notification library. Prior to 2.1.13 and 2.2.2-alpha, libevent has an incorrect integer conversion in event_tagging.c when evtag_unmarshal_header uses evtag_decode_int to decode an attacker-controlled uint32 payload length and returns it as a signed int. Values above INT_MAX become negative or truncated, and evtag_unmarshal_string can use the converted value in allocation sizing, producing a wrapped large allocation request and denial of service. This issue is fixed in versions 2.1.13 and 2.2.2-alpha.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:10libevent2.1.13-1.el10_2ALSA-2026:67909
AlmaLinux:8libevent2.1.8-11.el8_10ALSA-2026:67908
AlmaLinux:9libevent2.1.13-1.el9_8ALSA-2026:67910
AlmaLinux:10libevent-devel2.1.13-1.el10_2ALSA-2026:67909
AlmaLinux:8libevent-devel2.1.8-11.el8_10ALSA-2026:67908
AlmaLinux:9libevent-devel2.1.13-1.el9_8ALSA-2026:67910
AlmaLinux:10libevent-doc2.1.13-1.el10_2ALSA-2026:67909
AlmaLinux:8libevent-doc2.1.8-11.el8_10ALSA-2026:67908
AlmaLinux:9libevent-doc2.1.13-1.el9_8ALSA-2026:67910
Debian:12libevent2.1.12-stable-8+deb12u1DEBIAN-CVE-2026-63384
Debian:13libevent2.1.13-stable-1~deb13u1DEBIAN-CVE-2026-63384
Debian:14libevent2.1.13-stable-1DEBIAN-CVE-2026-63384
Rocky Linux:10libevent0:2.1.13-1.el10_2RLSA-2026:67909
Rocky Linux:8libevent0:2.1.8-11.el8_10RLSA-2026:67908
Rocky Linux:9libevent0:2.1.13-1.el9_8RLSA-2026:67910
Ubuntu:22.04:LTSlibevent2.1.12-stable-1ubuntu0.1UBUNTU-CVE-2026-63384
Ubuntu:22.04:LTSlibevent2.1.12-stable-1ubuntu0.1USN-8710-1
Ubuntu:24.04:LTSlibevent2.1.12-stable-9ubuntu2.1USN-8710-1
Ubuntu:24.04:LTSlibevent2.1.12-stable-9ubuntu2.1UBUNTU-CVE-2026-63384
Ubuntu:26.04:LTSlibevent2.1.12-stable-10ubuntu0.1USN-8710-1
Ubuntu:26.04:LTSlibevent2.1.12-stable-10ubuntu0.1UBUNTU-CVE-2026-63384

Affected products (as reported)

VendorProductVersions
libevent libevent >= 2.2.0-alpha, < 2.2.2-alpha< 2.1.13

Weakness: CWE-190 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

References