Vulnerability · Published Aug 20, 2026 · Assigned by GitHub_M
CVE-2026-63383Libevent: decode_tag_internal() can lead to out-of-bounds read
High 8.7
In plain English
A high-severity out-of-bounds read in libevent from libevent. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 42% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Libevent is an event notification library. Prior to 2.1.13 and 2.2.2-alpha, libevent can read beyond a contiguous evbuffer region in event_tagging.c when decode_tag_internal requests at most five bytes from evbuffer_pullup but iterates using the full logical buffer length. A fragmented evbuffer containing a six-byte malformed tag can therefore advance past the pullup window and trigger an out-of-bounds read, which can crash a process that decodes attacker-controlled tagged RPC data. This issue is fixed in versions 2.1.13 and 2.2.2-alpha.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| AlmaLinux:10 | libevent | 2.1.13-1.el10_2 | ALSA-2026:67909 |
| AlmaLinux:8 | libevent | 2.1.8-11.el8_10 | ALSA-2026:67908 |
| AlmaLinux:9 | libevent | 2.1.13-1.el9_8 | ALSA-2026:67910 |
| AlmaLinux:10 | libevent-devel | 2.1.13-1.el10_2 | ALSA-2026:67909 |
| AlmaLinux:8 | libevent-devel | 2.1.8-11.el8_10 | ALSA-2026:67908 |
| AlmaLinux:9 | libevent-devel | 2.1.13-1.el9_8 | ALSA-2026:67910 |
| AlmaLinux:10 | libevent-doc | 2.1.13-1.el10_2 | ALSA-2026:67909 |
| AlmaLinux:8 | libevent-doc | 2.1.8-11.el8_10 | ALSA-2026:67908 |
| AlmaLinux:9 | libevent-doc | 2.1.13-1.el9_8 | ALSA-2026:67910 |
| Debian:12 | libevent | 2.1.12-stable-8+deb12u1 | DEBIAN-CVE-2026-63383 |
| Debian:13 | libevent | 2.1.13-stable-1~deb13u1 | DEBIAN-CVE-2026-63383 |
| Debian:14 | libevent | 2.1.13-stable-1 | DEBIAN-CVE-2026-63383 |
| Rocky Linux:10 | libevent | 0:2.1.13-1.el10_2 | RLSA-2026:67909 |
| Rocky Linux:8 | libevent | 0:2.1.8-11.el8_10 | RLSA-2026:67908 |
| Rocky Linux:9 | libevent | 0:2.1.13-1.el9_8 | RLSA-2026:67910 |
| Ubuntu:22.04:LTS | libevent | 2.1.12-stable-1ubuntu0.1 | UBUNTU-CVE-2026-63383 |
| Ubuntu:22.04:LTS | libevent | 2.1.12-stable-1ubuntu0.1 | USN-8710-1 |
| Ubuntu:24.04:LTS | libevent | 2.1.12-stable-9ubuntu2.1 | USN-8710-1 |
| Ubuntu:24.04:LTS | libevent | 2.1.12-stable-9ubuntu2.1 | UBUNTU-CVE-2026-63383 |
| Ubuntu:26.04:LTS | libevent | 2.1.12-stable-10ubuntu0.1 | USN-8710-1 |
| Ubuntu:26.04:LTS | libevent | 2.1.12-stable-10ubuntu0.1 | UBUNTU-CVE-2026-63383 |
Affected products (as reported)
Weakness: CWE-125 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
References
- https://github.com/libevent/libevent/security/advisories/GHSA-fj29-64w6-73h6 x_refsource_CONFIRM
- https://github.com/libevent/libevent/commit/91ed8745eebabdd27592a83d350338a8c4626321 x_refsource_MISC
- https://github.com/libevent/libevent/commit/e1f9e21887c6b104e206a718385ba3ffc75180cb x_refsource_MISC
- https://github.com/libevent/libevent/releases/tag/release-2.1.13-stable x_refsource_MISC
- https://github.com/libevent/libevent/releases/tag/release-2.2.2-alpha x_refsource_MISC