Vulnerability · Published Aug 20, 2026 · Assigned by GitHub_M

CVE-2026-63382libevent evhttp: Multiple HTTP Parser Bugs Enable Request Smuggling

Critical 9.2

In plain English

A critical-severity security flaw in libevent from libevent. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 56% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)9.2Critical
Exploit odds (30 days)0.8%top 43.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

Libevent is an event notification library. Prior to 2.1.13 and 2.2.2-alpha, the libevent evhttp parser in http.c inconsistently handles duplicate Transfer-Encoding headers, comma-separated Transfer-Encoding values, and bare line feeds in chunked framing. evhttp_find_header can select only the first header, evhttp_check_transfer_encoding_ was absent so the previous whole-string comparison fails to recognize valid lists ending in chunked, and evhttp_handle_chunked_read uses EVBUFFER_EOL_CRLF rather than EVBUFFER_EOL_CRLF_STRICT, accepting bare LF chunk terminators. When libevent is deployed behind a proxy that frames the same request differently, an unauthenticated remote attacker can desynchronize request boundaries and smuggle a second request, potentially bypassing access controls or poisoning caches. This issue is fixed in versions 2.1.13 and 2.2.2-alpha.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:10libevent2.1.13-1.el10_2ALSA-2026:67909
AlmaLinux:8libevent2.1.8-11.el8_10ALSA-2026:67908
AlmaLinux:9libevent2.1.13-1.el9_8ALSA-2026:67910
AlmaLinux:10libevent-devel2.1.13-1.el10_2ALSA-2026:67909
AlmaLinux:8libevent-devel2.1.8-11.el8_10ALSA-2026:67908
AlmaLinux:9libevent-devel2.1.13-1.el9_8ALSA-2026:67910
AlmaLinux:10libevent-doc2.1.13-1.el10_2ALSA-2026:67909
AlmaLinux:8libevent-doc2.1.8-11.el8_10ALSA-2026:67908
AlmaLinux:9libevent-doc2.1.13-1.el9_8ALSA-2026:67910
Debian:12libevent2.1.12-stable-8+deb12u1DEBIAN-CVE-2026-63382
Debian:13libevent2.1.13-stable-1~deb13u1DEBIAN-CVE-2026-63382
Debian:14libevent2.1.13-stable-1DEBIAN-CVE-2026-63382
Rocky Linux:10libevent0:2.1.13-1.el10_2RLSA-2026:67909
Rocky Linux:8libevent0:2.1.8-11.el8_10RLSA-2026:67908
Rocky Linux:9libevent0:2.1.13-1.el9_8RLSA-2026:67910
Ubuntu:22.04:LTSlibevent2.1.12-stable-1ubuntu0.1UBUNTU-CVE-2026-63382
Ubuntu:22.04:LTSlibevent2.1.12-stable-1ubuntu0.1USN-8710-1
Ubuntu:24.04:LTSlibevent2.1.12-stable-9ubuntu2.1USN-8710-1
Ubuntu:24.04:LTSlibevent2.1.12-stable-9ubuntu2.1UBUNTU-CVE-2026-63382
Ubuntu:26.04:LTSlibevent2.1.12-stable-10ubuntu0.1USN-8710-1
Ubuntu:26.04:LTSlibevent2.1.12-stable-10ubuntu0.1UBUNTU-CVE-2026-63382

Affected products (as reported)

VendorProductVersions
libevent libevent >= 2.2.0-alpha, < 2.2.2-alpha< 2.1.13

Weakness: CWE-444 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:L/SC:L/SI:L/SA:N

References