Vulnerability · Published Oct 13, 2026 · Assigned by CERT-PL

CVE-2026-63316SQL Injection in Payload CMS

High 8.7

In plain English

A high-severity SQL injection in Payload CMS from Payload. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 18% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.7High
Exploit odds (30 days)0.3%top 82.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

A SQL injection vulnerability has been identified in Payload CMS. Improper neutralization of input provided by user into "in" and "not_in" query paramethers allows an authenticated attacker to perform SQL Injection attacks. This issue was fixed in version 3.90.0 and 4.0.0-canary.34.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npm@payloadcms/db-d1-sqlite3.90.0GHSA-pj7x-6wpf-pgvp
npm@payloadcms/db-d1-sqlite4.0.0-canary.34GHSA-pj7x-6wpf-pgvp
npm@payloadcms/db-postgres3.73.0GHSA-pj7x-6wpf-pgvp
npm@payloadcms/db-sqlite3.90.0GHSA-pj7x-6wpf-pgvp
npm@payloadcms/db-sqlite4.0.0-canary.34GHSA-pj7x-6wpf-pgvp
npm@payloadcms/db-vercel-postgres3.73.0GHSA-pj7x-6wpf-pgvp

Affected products (as reported)

VendorProductVersions
Payload Payload CMS 0 – before 3.90.04.0.0-canary.0 – before 4.0.0-canary.34

Weakness: CWE-89 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N

References