Vulnerability · Published Jul 31, 2026 · Assigned by GitHub_M

CVE-2026-63220CodeIgniter: Spoofable forwarded HTTPS headers in IncomingRequest::isSecure()

Medium 4.8

In plain English

A medium-severity security flaw in CodeIgniter4 from codeigniter4. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 6% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)4.8Medium
Exploit odds (30 days)0.2%top 93.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

CodeIgniter is a PHP full-stack web framework. In versions prior to 4.7.4, IncomingRequest::isSecure() trusted the X-Forwarded-Proto and Front-End-Https headers from any incoming request, allowing an attacker could spoof these headers and cause the application to incorrectly treat an HTTP request as secure. This may have impacted applications that rely on isSecure(), force_https(), forceGlobalSecureRequests, or similar logic to enforce HTTPS-only access or make security-sensitive decisions. Exploitability depends on deployment configuration. Applications are most exposed if the backend is reachable directly over HTTP, or if a reverse proxy/load balancer forwards client-supplied forwarding headers without stripping or overwriting them. This issue has been fixed in version 4.7.4.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistcodeigniter4/framework4.7.4GHSA-7wmf-pw8j-mc78
Ubuntu:24.04:LTSphp-codeigniter-frameworkno fix listedUBUNTU-CVE-2026-63220
Ubuntu:26.04:LTSphp-codeigniter-frameworkno fix listedUBUNTU-CVE-2026-63220
Ubuntu:26.10php-codeigniter-frameworkno fix listedUBUNTU-CVE-2026-63220

Affected products (as reported)

VendorProductVersions
codeigniter4 CodeIgniter4 < 4.7.4

Weakness: CWE-348 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N

References