Vulnerability · Published Aug 31, 2026 · Assigned by GitHub_M

CVE-2026-62993Smarty: SSRF via redirect bypass of trusted_uri using {fetch}

Medium 6.9

In plain English

A medium-severity server-side request forgery in smarty from smarty-php. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 48% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)6.9Medium
Exploit odds (30 days)0.6%top 52.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Smarty is a template engine for PHP, facilitating the separation of presentation (HTML/CSS) from application logic. Prior to 4.5.7 and 5.8.2, depending on the release line, Smarty's {fetch} handling in libs/plugins/function.fetch.php and src/FunctionHandler/Fetch.php used Security::isTrustedUri() to validate only the initial remote URL against trusted_uri when a security policy was active. For resources handled by file_get_contents(), including HTTPS URLs, PHP followed HTTP redirects by default. An attacker who could supply or influence a fetch target and had an open redirect on a trusted host could redirect the request to an attacker-chosen internal endpoint, bypass the trusted_uri allowlist, and perform server-side request forgery. This issue is fixed in versions 4.5.7 and 5.8.2.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12smarty3no fix listedDEBIAN-CVE-2026-62993
Debian:13smarty3no fix listedDEBIAN-CVE-2026-62993
Debian:14smarty3no fix listedDEBIAN-CVE-2026-62993
Debian:12smarty4no fix listedDEBIAN-CVE-2026-62993
Debian:13smarty4no fix listedDEBIAN-CVE-2026-62993
Debian:14smarty4no fix listedDEBIAN-CVE-2026-62993
Packagistsmarty/smarty5.8.2GHSA-cq55-c7wv-pxmq
Packagistsmarty/smarty4.5.7GHSA-cq55-c7wv-pxmq
Ubuntu:22.04:LTSsmarty3no fix listedUBUNTU-CVE-2026-62993
Ubuntu:24.04:LTSsmarty3no fix listedUBUNTU-CVE-2026-62993
Ubuntu:26.04:LTSsmarty3no fix listedUBUNTU-CVE-2026-62993
Ubuntu:26.10smarty3no fix listedUBUNTU-CVE-2026-62993
Ubuntu:24.04:LTSsmarty4no fix listedUBUNTU-CVE-2026-62993
Ubuntu:26.04:LTSsmarty4no fix listedUBUNTU-CVE-2026-62993
Ubuntu:26.10smarty4no fix listedUBUNTU-CVE-2026-62993

Affected products (as reported)

VendorProductVersions
smarty-php smarty >= 5.0.0, < 5.8.2< 4.5.7

Weakness: CWE-918 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:N/SA:N

References