Vulnerability · Published Aug 7, 2026 · Assigned by GitHub_M
CVE-2026-62992Smarty: Symlink path traversal out of trusted directories
Medium 6.9
In plain English
A medium-severity path traversal in smarty from smarty-php. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 45% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Smarty is a template engine for PHP, facilitating the separation of presentation (HTML/CSS) from application logic. Prior to 5.8.2 (and 4.5.7 on the 4.x line), Security::_checkDir() does not fully resolve symbolic links before validating that a requested path lies within a configured secure directory. An attacker able to place or reference a symlink within a directory Smarty treats as trusted (e.g., a template or config directory) could use it to point outside the intended secure directory, bypassing the containment check and reading arbitrary files accessible to the PHP process. This issue is fixed in versions 5.8.2 and 4.5.7.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | smarty3 | no fix listed | DEBIAN-CVE-2026-62992 |
| Debian:13 | smarty3 | no fix listed | DEBIAN-CVE-2026-62992 |
| Debian:14 | smarty3 | no fix listed | DEBIAN-CVE-2026-62992 |
| Debian:12 | smarty4 | no fix listed | DEBIAN-CVE-2026-62992 |
| Debian:13 | smarty4 | no fix listed | DEBIAN-CVE-2026-62992 |
| Debian:14 | smarty4 | no fix listed | DEBIAN-CVE-2026-62992 |
| Packagist | smarty/smarty | 5.8.2 | GHSA-f6wf-28g6-769x |
| Packagist | smarty/smarty | 4.5.7 | GHSA-f6wf-28g6-769x |
| Ubuntu:22.04:LTS | smarty3 | no fix listed | UBUNTU-CVE-2026-62992 |
| Ubuntu:24.04:LTS | smarty3 | no fix listed | UBUNTU-CVE-2026-62992 |
| Ubuntu:26.04:LTS | smarty3 | no fix listed | UBUNTU-CVE-2026-62992 |
| Ubuntu:26.10 | smarty3 | no fix listed | UBUNTU-CVE-2026-62992 |
| Ubuntu:24.04:LTS | smarty4 | no fix listed | UBUNTU-CVE-2026-62992 |
| Ubuntu:26.04:LTS | smarty4 | no fix listed | UBUNTU-CVE-2026-62992 |
| Ubuntu:26.10 | smarty4 | no fix listed | UBUNTU-CVE-2026-62992 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| smarty-php | smarty | >= 5.0.0, < 5.8.2< 4.5.7 |
Weakness: CWE-22, CWE-61 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N
References
- https://github.com/smarty-php/smarty/security/advisories/GHSA-f6wf-28g6-769x x_refsource_CONFIRM
- https://github.com/smarty-php/smarty/commit/99c048ce7a590c519b79fbd38ad0143a08183a1f x_refsource_MISC
- https://github.com/smarty-php/smarty/commit/a1ccdb0518021a559b4066c37b76a42c86bbce90 x_refsource_MISC
- https://github.com/smarty-php/smarty/releases/tag/v4.5.7 x_refsource_MISC
- https://github.com/smarty-php/smarty/releases/tag/v5.8.2 x_refsource_MISC