Vulnerability · Published Apr 16, 2026 · Assigned by openjs
CVE-2026-6270@fastify/middie vulnerable to middleware authentication bypass in child plugin scopes
Critical 9.1
In plain English
A critical-severity security flaw in @fastify/middie from @fastify/middie. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 43% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
@fastify/middie versions 9.3.1 and earlier do not register inherited middleware directly on child plugin engine instances. When a Fastify application registers authentication middleware in a parent scope and then registers child plugins with @fastify/middie, the child scope does not inherit the parent middleware. This allows unauthenticated requests to reach routes defined in child plugin scopes, bypassing authentication and authorization checks. Upgrade to @fastify/middie 9.3.2 to fix this issue. There are no workarounds.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | @fastify/middie | 9.3.2 | GHSA-72c6-fx6q-fr5w |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| @fastify/middie | @fastify/middie | 0 – before 9.3.2 |
Weakness: CWE-436 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N