Vulnerability · Published Aug 19, 2026 · Assigned by GitHub_M
CVE-2026-62670Fail-open authorization in grav-plugin-flex-objects admin-next API: api.access user gets full CRUD on permission-less directories (requireFlexPermission missing else-deny)
Medium 6.3
In plain English
A medium-severity missing authorization in grav-plugin-flex-objects from getgrav. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 27% of all known vulnerabilities).
Official description
Grav Flex Objects Plugin allows you to build custom collections of objects. Prior to 1.4.3, the Grav Flex Objects Admin Next API requireFlexPermission() method in classes/Api/FlexApiController.php returns without denying access when a directory blueprint omits config.admin.permissions. An authenticated account with only api.access can use the index, show, create, update, delete, export, and media handlers for a permission-less directory even though the core admin.flex-object. authorization fallback would deny the same actions. This issue is fixed in version 1.4.3.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| getgrav | grav-plugin-flex-objects | < 1.4.3 |
Weakness: CWE-862 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
References
- https://github.com/getgrav/grav/security/advisories/GHSA-23vq-365v-qcmh x_refsource_CONFIRM
- https://github.com/trilbymedia/grav-plugin-flex-objects/commit/198d1a0eb7b94777a026ed0001d9a369d94c3002 x_refsource_MISC
- https://github.com/trilbymedia/grav-plugin-flex-objects/releases/tag/1.4.3 x_refsource_MISC