Vulnerability · Published Jul 17, 2026 · Assigned by VulnCheck
CVE-2026-62387Grav < 1.0.0-rc.16 CORS Misconfiguration via API Plugin
High 7.1
In plain English
A high-severity security flaw in grav from getgrav. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 24% of all known vulnerabilities).
Official description
The Grav API plugin (getgrav/grav-plugin-api) before 1.0.0-rc.16 shipped Access-Control-Allow-Origin: * as its default CORS configuration on all responses, including authenticated endpoints and preflight (OPTIONS) responses. Because the plugin accepts credentials via the Authorization and X-API-Token headers (set programmatically by JavaScript rather than via cookies), an attacker who obtains a valid access token (e.g., via log leakage, Referer headers, browser history, or network capture) can issue fully authenticated cross-origin requests from any malicious website to read sensitive data and perform write operations as the token's user. Fixed in 1.0.0-rc.16.
Affected products (as reported)
Weakness: CWE-942 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N
References
- GitHub Security Advisory (GHSA-93px-98wh-6fj2) vendor-advisory
- VulnCheck Advisory: Grav < 1.0.0-rc.16 CORS Misconfiguration via API Plugin third-party-advisory