Vulnerability · Published Sep 22, 2026 · Assigned by GitHub_M
CVE-2026-62364wlc may disclose API tokens to project-configured URLs
Low 2.3
In plain English
A low-severity information exposure in wlc from WeblateOrg. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.1% (higher than 0% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
wlc is a Weblate command-line client using Weblate's REST API. Prior to 2.0.1, automatically discovered configuration from .weblate, .weblate.ini, or weblate.ini can select the API URL while an unscoped API token is supplied through WLC_KEY or --key without a matching WLC_URL or --url. When wlc runs in an untrusted repository, pull request checkout, or directory with untrusted ancestor configuration, it can send the token to an attacker-controlled project-configured URL. URL-scoped keys in [keys] are not affected. This issue is fixed in version 2.0.1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | wlc | no fix listed | DEBIAN-CVE-2026-62364 |
| Debian:13 | wlc | no fix listed | DEBIAN-CVE-2026-62364 |
| Debian:14 | wlc | 2.2.1-1 | DEBIAN-CVE-2026-62364 |
| PyPI | wlc | 2.0.1 | PYSEC-2026-4180 |
| PyPI | wlc | 2.0.1 | GHSA-3mqq-hv9c-85hc |
| Ubuntu:26.04:LTS | wlc | no fix listed | UBUNTU-CVE-2026-62364 |
| Ubuntu:26.10 | wlc | no fix listed | UBUNTU-CVE-2026-62364 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| WeblateOrg | wlc | < 2.0.1 |
Weakness: CWE-200, CWE-349 · Vector: CVSS:3.1/AV:L/AC:H/PR:H/UI:R/S:C/C:L/I:N/A:N
References
- https://github.com/WeblateOrg/wlc/security/advisories/GHSA-3mqq-hv9c-85hc x_refsource_CONFIRM
- https://github.com/WeblateOrg/wlc/pull/1500 x_refsource_MISC
- https://github.com/WeblateOrg/wlc/commit/15cbdfc5b2c6183ef6864ea758091643a0ce6c89 x_refsource_MISC
- https://github.com/WeblateOrg/wlc/releases/tag/2.0.1 x_refsource_MISC