Vulnerability · Published Jul 17, 2026 · Assigned by VulnCheck
CVE-2026-62231Grav < 1.0.6 API Key Scope Bypass via ApiKeyAuthenticator
High 8.1
In plain English
A high-severity incorrect authorization in grav from getgrav. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 21% of all known vulnerabilities).
Official description
The Grav API plugin (getgrav/grav-plugin-api) before 1.0.6 contains an authorization bypass: API keys can be created with a restricted scopes array, but the ApiKeyAuthenticator class never reads or enforces these scopes. It loads and returns the owning user's full account object, so a key created with limited scopes (e.g. read-only) can perform any write, delete, or administrative operation the owning user is authorized for. Fixed in 1.0.6.
Affected products (as reported)
Weakness: CWE-863 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
References
- GitHub Security Advisory (GHSA-x7hm-jc32-v39j) vendor-advisory
- VulnCheck Advisory: Grav < 1.0.6 API Key Scope Bypass via ApiKeyAuthenticator third-party-advisory