Vulnerability · Published Sep 25, 2026 · Assigned by GitHub_M

CVE-2026-61837RabbitMQ: AMQP 1.0 management `GET /bindings` exposes full binding topology to any authenticated AMQP user without resource/management permission checks

Medium 6.3

In plain English

A medium-severity missing authorization in rabbitmq-server from rabbitmq. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 23% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)6.3Medium
Exploit odds (30 days)0.3%top 77.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

RabbitMQ is a messaging and streaming broker. From 4.0.0 until 4.3.3, 4.2.9, 4.1.14, and 4.0.23, AMQP 1.0 management GET /bindings exposes full binding topology to any authenticated AMQP user without resource/management permission checks. the AMQP 1.0 HTTP-over-AMQP management endpoint GET /bindings (the rabbitamqpmanagement handler) enumerates bindings between an arbitrary source exchange and destination queue/exchange in the caller's virtual host without performing any resource-level permission check. Unlike every sibling operation in the same module (which call checkresourceaccess / bindingchecks), the GET handler ignores the authenticated User and returns the binding list unchanged. As a result, any authenticated AMQP 1.0 client that can open a management link pair , including users with no management/monitoring/policymaker/administrator tag , can enumerate the complete binding topology (source exchanges, destination queues/exchanges, routing keys, and binding arguments) of the virtual host they can access. The equivalent HTTP management API (GET /api/bindings) Confidentiality impact: a non-management AMQP 1.0 user can enumerate the complete routing topology of any virtual host it can connect to , every (source exchange, destination queue/exchange, routing key, binding arguments) This issue is fixed in versions 4.3.3, 4.2.9, 4.1.14, and 4.0.23.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12rabbitmq-serverno fix listedDEBIAN-CVE-2026-61837
Debian:13rabbitmq-serverno fix listedDEBIAN-CVE-2026-61837
Debian:14rabbitmq-server4.3.6-1DEBIAN-CVE-2026-61837
Ubuntu:22.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-61837
Ubuntu:24.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-61837
Ubuntu:26.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-61837
Ubuntu:26.10rabbitmq-serverno fix listedUBUNTU-CVE-2026-61837

Affected products (as reported)

VendorProductVersions
rabbitmq rabbitmq-server >= 4.3.0, < 4.3.3>= 4.2.0, < 4.2.9>= 4.1.0, < 4.1.14>= 4.0.0, < 4.0.23

Weakness: CWE-285, CWE-862 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:N/SA:N

References