Vulnerability · Published Nov 5, 2026 · Assigned by GitHub_M

CVE-2026-61813ModSecurity: Incorrect libcurl TLS hostname verification setting in HttpsClient::download

Low 3.7

In plain English

A low-severity improper certificate validation in ModSecurity from owasp-modsecurity. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 5% of all known vulnerabilities).

Severity (CVSS 3.1)3.7Low
Exploit odds (30 days)0.2%top 95.4% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. Prior to 2.9.15 and 3.0.17, the HttpsClient::download function in src/utils/https_client.cc sets libcurl CURLOPT_SSL_VERIFYHOST to 1 instead of the strict value 2L. Under adversary-in-the-middle and TLS interception conditions, this non-strict setting may weaken TLS peer identity validation and increase the risk of accepting a certificate for an unintended host. End-to-end exploitation is non-trivial in typical environments. This issue is fixed in versions 2.9.15 and 3.0.17.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12modsecurityno fix listedDEBIAN-CVE-2026-61813
Debian:13modsecurityno fix listedDEBIAN-CVE-2026-61813
Debian:14modsecurityno fix listedDEBIAN-CVE-2026-61813
Debian:12modsecurity-apacheno fix listedDEBIAN-CVE-2026-61813
Debian:13modsecurity-apacheno fix listedDEBIAN-CVE-2026-61813
Debian:14modsecurity-apacheno fix listedDEBIAN-CVE-2026-61813
Ubuntu:22.04:LTSmodsecurityno fix listedUBUNTU-CVE-2026-61813
Ubuntu:24.04:LTSmodsecurityno fix listedUBUNTU-CVE-2026-61813
Ubuntu:26.04:LTSmodsecurityno fix listedUBUNTU-CVE-2026-61813
Ubuntu:26.10modsecurityno fix listedUBUNTU-CVE-2026-61813
Ubuntu:26.04:LTSmodsecurity-apacheno fix listedUBUNTU-CVE-2026-61813
Ubuntu:26.10modsecurity-apacheno fix listedUBUNTU-CVE-2026-61813

Affected products (as reported)

VendorProductVersions
owasp-modsecurity ModSecurity < 2.9.15>= 3.0.0, < 3.0.17

Weakness: CWE-295 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N

References