Vulnerability · Published Jul 28, 2026 · Assigned by apache

CVE-2026-61487Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ: Authorization bypass via temporary composite destinations

Medium 6.5

In plain English

A medium-severity security flaw in Apache ActiveMQ from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 40% of all known vulnerabilities).

Severity (CVSS 3.1)6.5Medium
Exploit odds (30 days)0.5%top 60.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Improper Authorization vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ. An authenticated low-privilege user can bypass a per-destination write ACL by sending to an ActiveMQ temporary composite destination whose physical name is a comma-separated composite of real queues. This allows publishing messages to any of the destinations in the list without proper write ACL permissions because the authorization check is bypassed due to the composite destination being marked as temporary. This issue affects Apache ActiveMQ Broker: before 5.19.9, from 6.0.0 before 6.2.8; Apache ActiveMQ All: before 5.19.9, from 6.0.0 before 6.2.8; Apache ActiveMQ: before 5.19.9, from 6.0.0 before 6.2.8. Users are recommended to upgrade to version 5.19.9, 6.2.8 or 6.3.0, which fixes the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12activemqno fix listedDEBIAN-CVE-2026-61487
Debian:13activemqno fix listedDEBIAN-CVE-2026-61487
Ubuntu:24.04:LTSactivemqno fix listedUBUNTU-CVE-2026-61487
Ubuntu:26.04:LTSactivemqno fix listedUBUNTU-CVE-2026-61487
Ubuntu:26.10activemqno fix listedUBUNTU-CVE-2026-61487

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache ActiveMQ Broker 0 – before 5.19.96.0.0 – before 6.2.8
Apache Software Foundation Apache ActiveMQ All 0 – before 5.19.96.0.0 – before 6.2.8
Apache Software Foundation Apache ActiveMQ 0 – before 5.19.96.0.0 – before 6.2.8

Weakness: CWE-285 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N

References