Vulnerability · Published Aug 21, 2026 · Assigned by apache

CVE-2026-61399Apache CloudStack: Cross-Site Scripting (XSS) Vulnerability in Lock User Function in UI

Medium 4.8

In plain English

A medium-severity security flaw in Apache CloudStack from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 43% of all known vulnerabilities).

Severity (CVSS 3.1)4.8Medium
Exploit odds (30 days)0.5%top 56.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Improper Encoding or Escaping of Output vulnerability in Apache CloudStack's UI while using Lock User Functionality. This issue affects Apache CloudStack: from 4.20.0.0 through 4.20.3.0 and from 4.21.0.0 through 4.22.1.0. Users are recommended to upgrade to version 4.20.3.1 or 4.22.1.1 or later, which fixes the issue.

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache CloudStack 4.20.0.0 – through 4.20.3.04.21.0.0 – through 4.22.1.0

Weakness: CWE-116 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N

References