Vulnerability · Published Jul 8, 2026 · Assigned by GitHub_M

CVE-2026-59948Composer: Arbitrary file write outside vendor via malicious transitive package name

High 7.0

In plain English

A high-severity path traversal in composer from composer. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.1% (higher than 3% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.0High
Exploit odds (30 days)0.1%top 96.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Composer is a dependency Manager for the PHP language. Prior to 2.2.29 and 2.10.2, a maliciously crafted package from an untrusted repository other than Packagist.org or Private Packagist can cause Composer to write attacker-controlled files outside the vendor directory and outside the project during install or update by using an invalid package name that is not correctly validated before dependency-resolution results are written or installed. This issue is fixed in versions 2.2.29 and 2.10.2.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12composerno fix listedDEBIAN-CVE-2026-59948
Debian:13composerno fix listedDEBIAN-CVE-2026-59948
Debian:14composer2.10.2-1DEBIAN-CVE-2026-59948
Packagistcomposer/composer2.2.29GHSA-499r-g7pc-vmp9
Packagistcomposer/composer2.10.2GHSA-499r-g7pc-vmp9
Ubuntu:25.10composerno fix listedUBUNTU-CVE-2026-59948
Ubuntu:26.04:LTScomposerno fix listedUBUNTU-CVE-2026-59948
Ubuntu:26.10composerno fix listedUBUNTU-CVE-2026-59948

Affected products (as reported)

VendorProductVersions
composer composer >= 1.0, < 2.2.29>= 2.3.0, < 2.10.2

Weakness: CWE-22, CWE-787 · Vector: CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

References