Vulnerability · Published Jul 8, 2026 · Assigned by GitHub_M

CVE-2026-59946Composer: Path traversal in package bin field lets dependencies chmod arbitrary host files

Medium 6.1

In plain English

A medium-severity path traversal in composer from composer. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.1% (higher than 3% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.1Medium
Exploit odds (30 days)0.1%top 96.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Composer is a dependency Manager for the PHP language. Prior to 2.2.29 and 2.10.2, a Composer package bin entry containing .. path segments can resolve outside the package install directory and cause Composer's binary installation flow to chmod an existing host file to a world-readable and world-executable mode during composer install, update, or require. This issue is fixed in versions 2.2.29 and 2.10.2.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12composerno fix listedDEBIAN-CVE-2026-59946
Debian:13composerno fix listedDEBIAN-CVE-2026-59946
Debian:14composer2.10.2-1DEBIAN-CVE-2026-59946
Packagistcomposer/composer2.2.29GHSA-gjfg-22fp-rrxx
Packagistcomposer/composer2.10.2GHSA-gjfg-22fp-rrxx
Ubuntu:25.10composerno fix listedUBUNTU-CVE-2026-59946
Ubuntu:26.04:LTScomposerno fix listedUBUNTU-CVE-2026-59946
Ubuntu:26.10composerno fix listedUBUNTU-CVE-2026-59946

Affected products (as reported)

VendorProductVersions
composer composer >= 1.0, < 2.2.29>= 2.3.0, < 2.10.2

Weakness: CWE-22, CWE-732 · Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N

References