Vulnerability · Published Sep 16, 2026 · Assigned by GitHub_M

CVE-2026-59944Composer: CVE-2026-59946 fix bypass via symlinked package bin path

Medium 6.1

In plain English

A medium-severity path traversal in composer from composer. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 41% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.1Medium
Exploit odds (30 days)0.5%top 59.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Composer is a dependency Manager for the PHP language. From 1.0 until 2.2.30 and from 2.3.0 until 2.10.3, a malicious or compromised dependency can bypass the earlier CVE-2026-59946 binary-path hardening because Composer validates literal parent-directory segments only during dependency resolution, while the symlink and installed-metadata paths described by the advisory skip that validation. A package can ship an in-package binary symlink that resolves outside its installation directory, or attacker-influenced vendor/composer/installed.json metadata can provide an escaping binary path during a reinstall or regeneration of missing vendor/bin entries. The installed-metadata path is reachable only when the vendor directory was not populated by the same validated install run, such as when it is restored from an untrusted cache, copied from an earlier build stage, carried over from an older Composer run, or writable by a lower-trust build step. Composer can follow the path, change the external target's permissions to make it world-readable and executable, and create a runnable vendor/bin proxy to that external file. The issue does not directly read or transmit data and does not by itself provide remote code execution. This issue is fixed in versions 2.2.30 and 2.10.3.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.24composer2.10.3-r0ALPINE-CVE-2026-59944
Debian:12composerno fix listedDEBIAN-CVE-2026-59944
Debian:13composerno fix listedDEBIAN-CVE-2026-59944
Debian:14composer2.10.3-1DEBIAN-CVE-2026-59944
Packagistcomposer/composer2.2.30GHSA-96h3-5x6v-m776
Packagistcomposer/composer2.10.3GHSA-96h3-5x6v-m776
Ubuntu:26.04:LTScomposerno fix listedUBUNTU-CVE-2026-59944
Ubuntu:26.10composerno fix listedUBUNTU-CVE-2026-59944

Affected products (as reported)

VendorProductVersions
composer composer >= 1.0.0, < 2.2.30>= 2.3.0, < 2.10.3

Weakness: CWE-22, CWE-59 · Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N

References