Vulnerability · Published Jul 14, 2026 · Assigned by GitHub_M

CVE-2026-59885pyasn1: Quadratic complexity in OBJECT IDENTIFIER and RELATIVE-OID processing allows denial of service

High 7.5

In plain English

A high-severity uncontrolled resource consumption in pyasn1 from pyasn1. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 50% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.6%top 50.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

pyasn1 is a generic ASN.1 library for Python. Prior to 0.6.4, the BER, CER, and DER decoders process OBJECT IDENTIFIER and RELATIVE-OID values in quadratic time relative to the number of arcs, so a small crafted payload containing an OID with many arcs consumes excessive CPU per decode() call and can deny service to applications that decode untrusted ASN.1 data. The corresponding encoders have the same quadratic behavior when an application re-encodes previously decoded attacker-supplied values. This issue is fixed in version 0.6.4.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12pyasn10.4.8-3+deb12u3DEBIAN-CVE-2026-59885
Debian:13pyasn10.6.1-1+deb13u3DEBIAN-CVE-2026-59885
Debian:14pyasn10.6.4-1DEBIAN-CVE-2026-59885
PyPIpyasn10.6.4PYSEC-2026-3456
PyPIpyasn10.6.4GHSA-8ppf-4f7h-5ppj
Ubuntu:22.04:LTSpyasn10.4.8-1ubuntu0.3UBUNTU-CVE-2026-59885
Ubuntu:22.04:LTSpyasn10.4.8-1ubuntu0.3USN-8712-1
Ubuntu:24.04:LTSpyasn10.4.8-4ubuntu0.3USN-8712-1
Ubuntu:24.04:LTSpyasn10.4.8-4ubuntu0.3UBUNTU-CVE-2026-59885
Ubuntu:26.04:LTSpyasn10.6.3-1ubuntu0.1USN-8712-1
Ubuntu:26.04:LTSpyasn10.6.3-1ubuntu0.1UBUNTU-CVE-2026-59885

Affected products (as reported)

VendorProductVersions
pyasn1 pyasn1 < 0.6.4

Weakness: CWE-400, CWE-407 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References