Vulnerability · Published Jul 14, 2026 · Assigned by GitHub_M

CVE-2026-59884pyasn1 BER/CER/DER decoder denial of service via unbounded long-form tag IDs

High 7.5

In plain English

A high-severity uncontrolled resource consumption in pyasn1 from pyasn1. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 50% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.6%top 50.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

pyasn1 is a generic ASN.1 library for Python. Prior to 0.6.4, the BER decoder shared by the CER and DER codecs parses long-form tags by accumulating continuation octets without an upper bound on the tag ID size, allowing a crafted input to force construction of an arbitrarily large integer with CPU cost growing quadratically and to trigger unhandled ValueError exceptions in Python 3.11+ error formatting paths. Any application decoding untrusted BER, CER, or DER input is affected. This issue is fixed in version 0.6.4.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12pyasn10.4.8-3+deb12u3DEBIAN-CVE-2026-59884
Debian:13pyasn10.6.1-1+deb13u3DEBIAN-CVE-2026-59884
Debian:14pyasn10.6.4-1DEBIAN-CVE-2026-59884
PyPIpyasn10.6.4PYSEC-2026-3455
PyPIpyasn10.6.4GHSA-m4p7-r5rc-7g4j
Ubuntu:22.04:LTSpyasn10.4.8-1ubuntu0.3UBUNTU-CVE-2026-59884
Ubuntu:22.04:LTSpyasn10.4.8-1ubuntu0.3USN-8712-1
Ubuntu:24.04:LTSpyasn10.4.8-4ubuntu0.3USN-8712-1
Ubuntu:24.04:LTSpyasn10.4.8-4ubuntu0.3UBUNTU-CVE-2026-59884
Ubuntu:26.04:LTSpyasn10.6.3-1ubuntu0.1USN-8712-1
Ubuntu:26.04:LTSpyasn10.6.3-1ubuntu0.1UBUNTU-CVE-2026-59884

Affected products (as reported)

VendorProductVersions
pyasn1 pyasn1 < 0.6.4

Weakness: CWE-400 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References