Vulnerability · Published Jul 8, 2026 · Assigned by GitHub_M

CVE-2026-59869js-yaml: YAML merge-key chains can force quadratic CPU consumption

High 7.5

In plain English

A high-severity security flaw in js-yaml from nodeca. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 48% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.6%top 51.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

js-yaml is a JavaScript YAML parser and dumper. From 3.0.0 before 3.15.0 and from 4.0.0 before 4.3.0, js-yaml can spend quadratic CPU time parsing a document whose size grows only linearly when a chain of mappings uses merge keys where each mapping merges the previous one. This issue is fixed in versions 3.15.0 and 4.3.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12node-js-yamlno fix listedDEBIAN-CVE-2026-59869
Debian:13node-js-yamlno fix listedDEBIAN-CVE-2026-59869
Debian:14node-js-yaml4.2.0+~4.0.9-2DEBIAN-CVE-2026-59869
Ubuntu:22.04:LTSnode-js-yamlno fix listedUBUNTU-CVE-2026-59869
Ubuntu:24.04:LTSnode-js-yamlno fix listedUBUNTU-CVE-2026-59869
Ubuntu:25.10node-js-yamlno fix listedUBUNTU-CVE-2026-59869
Ubuntu:26.04:LTSnode-js-yamlno fix listedUBUNTU-CVE-2026-59869
Ubuntu:26.10node-js-yamlno fix listedUBUNTU-CVE-2026-59869
npmjs-yaml3.15.0GHSA-52cp-r559-cp3m
npmjs-yaml4.3.0GHSA-52cp-r559-cp3m

Affected products (as reported)

VendorProductVersions
nodeca js-yaml >= 3.0.0, < 3.15.0>= 4.0.0, < 4.3.0

Weakness: CWE-407 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References