Vulnerability · Published Jul 9, 2026 · Assigned by GitHub_M
CVE-2026-59858Vim: Arbitrary Code Execution via C Omni-Completion
High 8.4
In plain English
A high-severity code injection in vim from vim. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.1% (higher than 3% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Vim is an open source, command line text editor. Prior to 9.2.0735, the C omni-completion script in runtime/autoload/ccomplete.vim interpolates the typeref: or typename: extension field of a tags entry, without escaping, into a :vimgrep pattern that is run through :execute. Because :vimgrep honors the bar as a command separator, a crafted tag field can close the search pattern and append an arbitrary Ex command; opening a hostile .c file whose project tags file contains such an entry and invoking C omni-completion runs that command as the editing user. This issue is fixed in version 9.2.0735.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| AlmaLinux:10 | vim-X11 | 2:9.1.083-9.el10_2.12 | ALSA-2026:48650 |
| AlmaLinux:8 | vim-X11 | 2:8.0.1763-31.el8_10 | ALSA-2026:48703 |
| AlmaLinux:9 | vim-X11 | 2:8.2.2637-26.el9_8.13 | ALSA-2026:47982 |
| AlmaLinux:10 | vim-common | 2:9.1.083-9.el10_2.12 | ALSA-2026:48650 |
| AlmaLinux:8 | vim-common | 2:8.0.1763-31.el8_10 | ALSA-2026:48703 |
| AlmaLinux:9 | vim-common | 2:8.2.2637-26.el9_8.13 | ALSA-2026:47982 |
| AlmaLinux:10 | vim-data | 2:9.1.083-9.el10_2.12 | ALSA-2026:48650 |
| AlmaLinux:10 | vim-enhanced | 2:9.1.083-9.el10_2.12 | ALSA-2026:48650 |
| AlmaLinux:8 | vim-enhanced | 2:8.0.1763-31.el8_10 | ALSA-2026:48703 |
| AlmaLinux:9 | vim-enhanced | 2:8.2.2637-26.el9_8.13 | ALSA-2026:47982 |
| AlmaLinux:10 | vim-filesystem | 2:9.1.083-9.el10_2.12 | ALSA-2026:48650 |
| AlmaLinux:8 | vim-filesystem | 2:8.0.1763-31.el8_10 | ALSA-2026:48703 |
| AlmaLinux:9 | vim-filesystem | 2:8.2.2637-26.el9_8.13 | ALSA-2026:47982 |
| AlmaLinux:10 | vim-minimal | 2:9.1.083-9.el10_2.12 | ALSA-2026:48650 |
| AlmaLinux:8 | vim-minimal | 2:8.0.1763-31.el8_10 | ALSA-2026:48703 |
| AlmaLinux:9 | vim-minimal | 2:8.2.2637-26.el9_8.13 | ALSA-2026:47982 |
| AlmaLinux:10 | xxd | 2:9.1.083-9.el10_2.12 | ALSA-2026:48650 |
| Alpine:v3.23 | vim | 9.2.0854-r0 | ALPINE-CVE-2026-59858 |
| Alpine:v3.24 | vim | 9.2.0735-r0 | ALPINE-CVE-2026-59858 |
| Debian:12 | vim | no fix listed | DEBIAN-CVE-2026-59858 |
| Debian:13 | vim | 2:9.1.1230-2+deb13u1 | DEBIAN-CVE-2026-59858 |
| Debian:14 | vim | 2:9.2.0782-1 | DEBIAN-CVE-2026-59858 |
| Rocky Linux:10 | vim | 2:9.1.083-9.el10_2.12 | RLSA-2026:48650 |
| Rocky Linux:8 | vim | 2:8.0.1763-31.el8_10 | RLSA-2026:48703 |
| Rocky Linux:9 | vim | 2:8.2.2637-26.el9_8.13 | RLSA-2026:47982 |
| Ubuntu:22.04:LTS | vim | 2:8.2.3995-1ubuntu2.34 | UBUNTU-CVE-2026-59858 |
| Ubuntu:22.04:LTS | vim | 2:8.2.3995-1ubuntu2.34 | USN-8541-1 |
| Ubuntu:24.04:LTS | vim | 2:9.1.0016-1ubuntu7.18 | UBUNTU-CVE-2026-59858 |
| Ubuntu:24.04:LTS | vim | 2:9.1.0016-1ubuntu7.18 | USN-8541-1 |
| Ubuntu:26.04:LTS | vim | 2:9.1.2141-1ubuntu4.7 | UBUNTU-CVE-2026-59858 |
| Ubuntu:26.04:LTS | vim | 2:9.1.2141-1ubuntu4.7 | USN-8541-1 |
Affected products (as reported)
Weakness: CWE-94 · Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
References
- https://github.com/vim/vim/security/advisories/GHSA-mf92-v4xw-j45x x_refsource_CONFIRM
- https://github.com/vim/vim/commit/6b611b0d15603c52ebdad17172b0232b4f65704e x_refsource_MISC