Vulnerability · Published Jul 9, 2026 · Assigned by GitHub_M

CVE-2026-59856Vim: Arbitrary Code Execution via PHP Omni-Completion

High 8.4

In plain English

A high-severity code injection in vim from vim. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 12% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.4High
Exploit odds (30 days)0.2%top 87.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Vim is an open source, command line text editor. Prior to 9.2.0736, the PHP omni-completion script in runtime/autoload/phpcomplete.vim interpolates a class or trait name, taken from the contents of the edited buffer, into a search() pattern that is run via win_execute() without escaping. A name containing a single quote can terminate the search() string argument early, and because the bar is honored as an Ex command separator, the remainder of the name is run as Ex commands; via the :! command this allows arbitrary operating-system command execution when a victim opens a crafted PHP file and invokes omni-completion. This issue is fixed in version 9.2.0736.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:10vim-X112:9.1.083-9.el10_2.12ALSA-2026:48650
AlmaLinux:9vim-X112:8.2.2637-26.el9_8.13ALSA-2026:47982
AlmaLinux:10vim-common2:9.1.083-9.el10_2.12ALSA-2026:48650
AlmaLinux:9vim-common2:8.2.2637-26.el9_8.13ALSA-2026:47982
AlmaLinux:10vim-data2:9.1.083-9.el10_2.12ALSA-2026:48650
AlmaLinux:10vim-enhanced2:9.1.083-9.el10_2.12ALSA-2026:48650
AlmaLinux:9vim-enhanced2:8.2.2637-26.el9_8.13ALSA-2026:47982
AlmaLinux:10vim-filesystem2:9.1.083-9.el10_2.12ALSA-2026:48650
AlmaLinux:9vim-filesystem2:8.2.2637-26.el9_8.13ALSA-2026:47982
AlmaLinux:10vim-minimal2:9.1.083-9.el10_2.12ALSA-2026:48650
AlmaLinux:9vim-minimal2:8.2.2637-26.el9_8.13ALSA-2026:47982
AlmaLinux:10xxd2:9.1.083-9.el10_2.12ALSA-2026:48650
Alpine:v3.23vim9.2.0854-r0ALPINE-CVE-2026-59856
Alpine:v3.24vim9.2.0747-r0ALPINE-CVE-2026-59856
Debian:12vimno fix listedDEBIAN-CVE-2026-59856
Debian:13vim2:9.1.1230-2+deb13u1DEBIAN-CVE-2026-59856
Debian:14vim2:9.2.0782-1DEBIAN-CVE-2026-59856
Rocky Linux:10vim2:9.1.083-9.el10_2.12RLSA-2026:48650
Rocky Linux:9vim2:8.2.2637-26.el9_8.13RLSA-2026:47982
Ubuntu:22.04:LTSvim2:8.2.3995-1ubuntu2.34USN-8541-1
Ubuntu:22.04:LTSvim2:8.2.3995-1ubuntu2.34UBUNTU-CVE-2026-59856
Ubuntu:24.04:LTSvim2:9.1.0016-1ubuntu7.18UBUNTU-CVE-2026-59856
Ubuntu:24.04:LTSvim2:9.1.0016-1ubuntu7.18USN-8541-1
Ubuntu:26.04:LTSvim2:9.1.2141-1ubuntu4.7USN-8541-1
Ubuntu:26.04:LTSvim2:9.1.2141-1ubuntu4.7UBUNTU-CVE-2026-59856

Affected products (as reported)

VendorProductVersions
vim vim < 9.2.0736

Weakness: CWE-94 · Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

References