Vulnerability · Published Sep 16, 2026 · Assigned by GitHub_M

CVE-2026-59823LiteLLM: Server-side request forgery via the `user_config` request parameter in LiteLLM Proxy

Medium 5.3

In plain English

A medium-severity server-side request forgery in litellm from BerriAI. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 38% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)5.3Medium
Exploit odds (30 days)0.4%top 61.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. Prior to 1.83.9, an authenticated LiteLLM Proxy caller with a valid virtual key can place api_base inside the user_config request body to bypass is_request_body_safe, which blocks top-level api_base and base_url but previously did not inspect or reject user_config. Because user_config constructs the outbound router, the nested destination redirects a server-side request to an internal or external host selected by the caller and can expose endpoints the caller cannot otherwise access. This issue is fixed in version 1.83.9.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIlitellm1.83.9GHSA-hx8v-g79f-8w5f
PyPIlitellm1.83.9PYSEC-2026-4070

Affected products (as reported)

VendorProductVersions
BerriAI litellm < 1.83.9

Weakness: CWE-918 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:L/SI:N/SA:N

References