Vulnerability · Published Jul 9, 2026 · Assigned by GitHub_M
CVE-2026-59207n8n: "Allowed HTTP Request Domains" Restriction Bypass via AI Agents MCP Connector
High 7.1
In plain English
A high-severity security flaw in n8n from n8n-io. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 39% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
n8n is an open source workflow automation platform. Prior to 2.27.4 and 2.28.1, the AI Agents feature did not enforce the Allowed HTTP Request Domains restriction configured on credentials when an MCP tool was pointed at an arbitrary URL, allowing a member-level user with use-only access to a shared credential to send its secret to an external server they control. This issue is fixed in versions 2.27.4 and 2.28.1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | n8n | 2.28.1 | GHSA-h44j-f5r5-ph73 |
| npm | n8n | 2.27.4 | GHSA-h44j-f5r5-ph73 |
Affected products (as reported)
Weakness: CWE-693 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:L/VA:N/SC:H/SI:L/SA:N
References
- https://github.com/n8n-io/n8n/security/advisories/GHSA-h44j-f5r5-ph73 x_refsource_CONFIRM
- https://github.com/n8n-io/n8n/releases/tag/n8n%402.27.4 x_refsource_MISC
- https://github.com/n8n-io/n8n/releases/tag/n8n%402.28.1 x_refsource_MISC