Vulnerability · Published Aug 25, 2026 · Assigned by GitHub_M
CVE-2026-59184OpenEXR: OpenEXRUtil FlatImageChannel row nonzero dataWindow heap OOB write
High 7.1
In plain English
A high-severity use-after-free in openexr from AcademySoftwareFoundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 12% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
OpenEXR is the reference implementation and specification for the EXR image format, widely used in the motion picture industry. Versions before 3.2.11, 3.3.0 through 3.3.12, and 3.4.0 through 3.4.13 allow a crafted EXR with a nonzero dataWindow.min to make TypedFlatImageChannel::row() return an invalid heap pointer, causing out-of-bounds or use-after-free writes. This occurs when an application writes rows through FlatHalfChannel::row(). Affected consumers are tools, converters, render pipeline components, or image-processing services that accept untrusted EXR files and use FlatHalfChannel::row() on loaded images. This issue is fixed in versions 3.2.11, 3.3.13, and 3.4.14.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| AlmaLinux:8 | OpenEXR-devel | 2.2.0-12.el8_10.3 | ALSA-2026:82345 |
| AlmaLinux:8 | OpenEXR-libs | 2.2.0-12.el8_10.3 | ALSA-2026:82345 |
| AlmaLinux:10 | openexr | 3.1.10-8.el10_2.5 | ALSA-2026:84796 |
| AlmaLinux:10 | openexr-devel | 3.1.10-8.el10_2.5 | ALSA-2026:84796 |
| AlmaLinux:9 | openexr-devel | 3.1.1-3.el9_8.5 | ALSA-2026:86983 |
| AlmaLinux:10 | openexr-libs | 3.1.10-8.el10_2.5 | ALSA-2026:84796 |
| Alpine:v3.24 | openexr | 3.4.15-r0 | ALPINE-CVE-2026-59184 |
| Debian:12 | openexr | no fix listed | DEBIAN-CVE-2026-59184 |
| Debian:13 | openexr | no fix listed | DEBIAN-CVE-2026-59184 |
| Debian:14 | openexr | 3.4.14-0.1 | DEBIAN-CVE-2026-59184 |
| Rocky Linux:8 | OpenEXR | 0:2.2.0-12.el8_10.3 | RLSA-2026:82345 |
| Rocky Linux:10 | openexr | 0:3.1.10-8.el10_2.5 | RLSA-2026:84796 |
| Rocky Linux:9 | openexr | 0:3.1.1-3.el9_8.5 | RLSA-2026:86983 |
| Ubuntu:26.10 | openexr | no fix listed | UBUNTU-CVE-2026-59184 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| AcademySoftwareFoundation | openexr | < 3.2.11>= 3.3.0, < 3.3.13>= 3.4.0, < 3.4.14 |
Weakness: CWE-416, CWE-787 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:H
References
- https://github.com/AcademySoftwareFoundation/openexr/security/advisories/GHSA-pqp9-558c-453q x_refsource_CONFIRM
- https://github.com/AcademySoftwareFoundation/openexr/commit/37f03b6ed90f3dd9910f31de3a40f25f2bc2aca1 x_refsource_MISC
- https://github.com/AcademySoftwareFoundation/openexr/commit/55b7958ecb5ac32c427ff39c1e063f6f7bbee77c x_refsource_MISC
- https://github.com/AcademySoftwareFoundation/openexr/commit/aef02224ba282a802de65d16c49c1cdb82089dec x_refsource_MISC