Vulnerability · Published Jul 14, 2026 · Assigned by apache

CVE-2026-59083Apache Tomcat: Incorrect URL decoding in RewriteValve may allow security control bypass

Critical 9.1

In plain English

A critical-severity security flaw in Apache Tomcat from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 44% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)9.1Critical
Exploit odds (30 days)0.5%top 55.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Improper Handling of URL Encoding (Hex Encoding) vulnerability in Apache Tomcat's rewrite valve allowed security constraint bypass for some configurations. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.23, from 10.1.0-M1 through 10.1.56, from 9.0.0.M1 through 9.0.119, from 8.5.0 through 8.5.100. Other versions that have reached end of support may also be affected. Users are recommended to upgrade to version 11.0.24, 10.1.57 or 9.0.120, which fix the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8tomcat1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:9tomcat1:9.0.120-2.el9_8ALSA-2026:68660
AlmaLinux:8tomcat-admin-webapps1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:9tomcat-admin-webapps1:9.0.120-2.el9_8ALSA-2026:68660
AlmaLinux:8tomcat-docs-webapp1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:9tomcat-docs-webapp1:9.0.120-2.el9_8ALSA-2026:68660
AlmaLinux:8tomcat-el-3.0-api1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:9tomcat-el-3.0-api1:9.0.120-2.el9_8ALSA-2026:68660
AlmaLinux:8tomcat-jsp-2.3-api1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:9tomcat-jsp-2.3-api1:9.0.120-2.el9_8ALSA-2026:68660
AlmaLinux:8tomcat-lib1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:9tomcat-lib1:9.0.120-2.el9_8ALSA-2026:68660
AlmaLinux:8tomcat-servlet-4.0-api1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:9tomcat-servlet-4.0-api1:9.0.120-2.el9_8ALSA-2026:68660
AlmaLinux:8tomcat-webapps1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:9tomcat-webapps1:9.0.120-2.el9_8ALSA-2026:68660
AlmaLinux:10tomcat91:9.0.120-1.el10_2.alma.1ALSA-2026:68651
AlmaLinux:10tomcat9-admin-webapps1:9.0.120-1.el10_2.alma.1ALSA-2026:68651
AlmaLinux:10tomcat9-docs-webapp1:9.0.120-1.el10_2.alma.1ALSA-2026:68651
AlmaLinux:10tomcat9-el-3.0-api1:9.0.120-1.el10_2.alma.1ALSA-2026:68651
AlmaLinux:10tomcat9-jsp-2.3-api1:9.0.120-1.el10_2.alma.1ALSA-2026:68651
AlmaLinux:10tomcat9-lib1:9.0.120-1.el10_2.alma.1ALSA-2026:68651
AlmaLinux:10tomcat9-servlet-4.0-api1:9.0.120-1.el10_2.alma.1ALSA-2026:68651
AlmaLinux:10tomcat9-webapps1:9.0.120-1.el10_2.alma.1ALSA-2026:68651
Debian:12tomcat10no fix listedDEBIAN-CVE-2026-59083
Debian:13tomcat10no fix listedDEBIAN-CVE-2026-59083
Debian:14tomcat1010.1.60-1DEBIAN-CVE-2026-59083
Debian:13tomcat11no fix listedDEBIAN-CVE-2026-59083
Debian:14tomcat1111.0.24-1DEBIAN-CVE-2026-59083
Debian:12tomcat99.0.70-2DEBIAN-CVE-2026-59083
Debian:13tomcat99.0.70-2DEBIAN-CVE-2026-59083
Debian:14tomcat99.0.70-2DEBIAN-CVE-2026-59083
Rocky Linux:8tomcat1:9.0.120-1.el8_10RLSA-2026:68677
Rocky Linux:9tomcat1:9.0.120-2.el9_8RLSA-2026:68660
Rocky Linux:10tomcat91:9.0.120-1.el10_2RLSA-2026:68651
Ubuntu:24.04:LTStomcat10no fix listedUBUNTU-CVE-2026-59083
Ubuntu:26.04:LTStomcat10no fix listedUBUNTU-CVE-2026-59083
Ubuntu:26.10tomcat10no fix listedUBUNTU-CVE-2026-59083
Ubuntu:26.04:LTStomcat11no fix listedUBUNTU-CVE-2026-59083
Ubuntu:26.10tomcat11no fix listedUBUNTU-CVE-2026-59083
Ubuntu:24.04:LTStomcat9no fix listedUBUNTU-CVE-2026-59083
Ubuntu:26.04:LTStomcat9no fix listedUBUNTU-CVE-2026-59083
Ubuntu:26.10tomcat9no fix listedUBUNTU-CVE-2026-59083

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Tomcat 11.0.0-M1 – through 11.0.2310.1.0-M1 – through 10.1.569.0.0.M1 – through 9.0.1198.5.0 – through 8.5.100

Weakness: CWE-177 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

References