Vulnerability · Published Jul 8, 2026 · Assigned by GitHub_M

CVE-2026-58501Zeep SSRF because Settings.forbid_external is not enforced

Medium 5.9

In plain English

A medium-severity server-side request forgery in python-zeep from mvantellingen. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 35% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.9Medium
Exploit odds (30 days)0.4%top 64.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Zeep is a Python SOAP client. From 4.0.0 before 4.3.3, Settings.forbid_external is defined but not enforced when parsing WSDL or XSD documents, allowing transitive xsd:import, xsd:include, wsdl:import, and lxml entity or DTD references to fetch attacker-chosen HTTP or HTTPS URLs. This issue is fixed in version 4.3.3.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12python-zeepno fix listedDEBIAN-CVE-2026-58501
Debian:13python-zeepno fix listedDEBIAN-CVE-2026-58501
Debian:14python-zeep4.3.3-1DEBIAN-CVE-2026-58501
PyPIzeep4.3.3GHSA-4cc2-g9w2-fhf6
PyPIzeep4.3.3PYSEC-2026-2323
Ubuntu:22.04:LTSpython-zeepno fix listedUBUNTU-CVE-2026-58501
Ubuntu:24.04:LTSpython-zeepno fix listedUBUNTU-CVE-2026-58501
Ubuntu:25.10python-zeepno fix listedUBUNTU-CVE-2026-58501
Ubuntu:26.04:LTSpython-zeepno fix listedUBUNTU-CVE-2026-58501
Ubuntu:26.10python-zeepno fix listedUBUNTU-CVE-2026-58501

Affected products (as reported)

VendorProductVersions
mvantellingen python-zeep >= 4.0.0, < 4.3.3

Weakness: CWE-918 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

References