Vulnerability · Published Jul 7, 2026 · Assigned by GitHub_M

CVE-2026-58266Anki: User scripts in iframes have access to the internal Anki API

Medium 6.5

In plain English

A medium-severity security flaw in anki from ankitects. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 13% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.5Medium
Exploit odds (30 days)0.2%top 87.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Anki is a program for creating and reviewing flashcards. Prior to 25.09.4, Anki's webview-based pages communicate with the Rust backend using an internal localhost API, and user scripts included via iframes in the editor can access this API despite protections intended to block reviewer and editor scripts. A malicious imported card package with an embedded iframe can use exposed API methods such as getImageForOcclusion to read arbitrary files accessible to the Anki process and exfiltrate them over the network. This issue is fixed in version 25.09.4.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIaqt25.9.4GHSA-cw6h-ffmh-x6vh
Ubuntu:22.04:LTSankino fix listedUBUNTU-CVE-2026-58266
Ubuntu:24.04:LTSankino fix listedUBUNTU-CVE-2026-58266

Affected products (as reported)

VendorProductVersions
ankitects anki < 25.09.4

Weakness: CWE-346 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N

References