Vulnerability · Published Oct 27, 2026 · Assigned by GitHub_M
CVE-2026-58256GRR vulnerable to Remote Code Execution Via PHP Code Injection
Critical 9.1
In plain English
A critical-severity code injection in GRR from JeromeDevome. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 48% of all known vulnerabilities).
Official description
GRR is a resource management and reservation application. Prior to the advisory-reported fixed version 4.5.0, an administrator can inject malicious PHP through LDAP connector configuration parameters such as `ldap_filter`, poisoning `/personnalisation/config_ldap.inc.php` and permitting remote code execution. The administrator must first successfully connect to an LDAP server, which can be attacker-controlled, and then submit malicious input on the subsequent connector settings page. The advisory reports this issue as fixed in version 4.5.0.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| JeromeDevome | GRR | < 4.5.0 |
Weakness: CWE-94 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H
References
- https://github.com/JeromeDevome/GRR/security/advisories/GHSA-fp4f-xmw6-5jf8 x_refsource_CONFIRM
- https://github.com/JeromeDevome/GRR/commit/3ff9504ae557da1e8e208149acbf8c7f04de645f x_refsource_MISC
- https://github.com/JeromeDevome/GRR/tree/v4.5.0 x_refsource_MISC