Vulnerability · Published Jul 8, 2026 · Assigned by GitHub_M

CVE-2026-58252NATS Server: Subscribe Authz Bypass via Wildcard-Overlap

Medium 6.5

In plain English

A medium-severity security flaw in nats-server from nats-io. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 40% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.5Medium
Exploit odds (30 days)0.5%top 59.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

NATS Server is a high-performance server for NATS.io, the cloud and edge native messaging system. Prior to 2.14.0, 2.12.7, and 2.11.16, an authenticated user could receive messages on denied subjects when a wildcard subscription overlapped with a configured wildcard deny rule but was not a subset of it, and queue subscriptions could also affect delivery to legitimate queue consumers. This issue is fixed in versions 2.14.0, 2.12.7, and 2.11.16.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12nats-serverno fix listedDEBIAN-CVE-2026-58252
Debian:13nats-serverno fix listedDEBIAN-CVE-2026-58252
Debian:14nats-server2.14.1-1DEBIAN-CVE-2026-58252
Ubuntu:24.04:LTSnats-serverno fix listedUBUNTU-CVE-2026-58252
Ubuntu:25.10nats-serverno fix listedUBUNTU-CVE-2026-58252

Affected products (as reported)

VendorProductVersions
nats-io nats-server < 2.11.16>= 2.12.0-preview.1, < 2.12.7

Weakness: CWE-285 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

References