Vulnerability · Published Jul 8, 2026 · Assigned by GitHub_M
CVE-2026-58211NATS Server: `no_auth_user` pre-CONNECT fast path bypasses user connection restrictions
Medium 5.4
In plain English
A medium-severity incorrect authorization in nats-server from nats-io. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 22% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
NATS Server is a high-performance server for NATS.io, the cloud and edge native messaging system. Prior to 2.14.3 and 2.12.12, a client could be registered as the configured no_auth_user through a parser path used when the first client operation was not CONNECT, bypassing user-level connection restrictions such as allowed_connection_types or proxy_required that normal authentication would apply. This issue is fixed in versions 2.14.3 and 2.12.12.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | nats-server | no fix listed | DEBIAN-CVE-2026-58211 |
| Debian:13 | nats-server | no fix listed | DEBIAN-CVE-2026-58211 |
| Debian:14 | nats-server | 2.14.3-1 | DEBIAN-CVE-2026-58211 |
| Ubuntu:24.04:LTS | nats-server | no fix listed | UBUNTU-CVE-2026-58211 |
| Ubuntu:25.10 | nats-server | no fix listed | UBUNTU-CVE-2026-58211 |
| Ubuntu:26.10 | nats-server | no fix listed | UBUNTU-CVE-2026-58211 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| nats-io | nats-server | < 2.12.12>= 2.14.0-RC.1, < 2.14.3 |
Weakness: CWE-863 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
References
- https://github.com/nats-io/nats-server/security/advisories/GHSA-hmmp-q8cx-v964 x_refsource_CONFIRM