Vulnerability · Published Jul 29, 2026 · Assigned by apache
CVE-2026-58188Apache Traffic Server: Memory-safety and limit-bypass errors across experimental plugins
High 8.2
In plain English
A high-severity out-of-bounds write in Apache Traffic Server from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 56% of all known vulnerabilities).
Severity (CVSS 3.1)8.2High
Exploit odds (30 days)0.8%top 44.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
Several Apache Traffic Server experimental plugins have memory-safety and limit-bypass errors. This issue affects Apache Traffic Server: from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.14, from 10.0.0 through 10.1.3. Users are recommended to upgrade to version 9.2.15 or 10.1.4, which fix the issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | trafficserver | no fix listed | DEBIAN-CVE-2026-58188 |
| Ubuntu:24.04:LTS | trafficserver | no fix listed | UBUNTU-CVE-2026-58188 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Traffic Server | 8.0.0 – through 8.1.119.0.0 – through 9.2.1410.0.0 – through 10.1.3 |
Weakness: CWE-787 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H
References
- https://lists.apache.org/thread/5prl9glcm9g2swnq9hqxvnokylm1gr6d vendor-advisory