Vulnerability · Published Jul 29, 2026 · Assigned by apache
CVE-2026-58187Apache Traffic Server: Multiplexer plugin chunk decoder enables a denial of service
Low 3.7
In plain English
A low-severity out-of-bounds write in Apache Traffic Server from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 48% of all known vulnerabilities).
Severity (CVSS 3.1)3.7Low
Exploit odds (30 days)0.6%top 51.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
The Apache Traffic Server multiplexer plugin overruns its chunk-decode buffer on upstream input, enabling denial of service. This issue affects Apache Traffic Server: from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.14, from 10.0.0 through 10.1.3. Users are recommended to upgrade to version 9.2.15 or 10.1.4, which fix the issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | trafficserver | no fix listed | DEBIAN-CVE-2026-58187 |
| Ubuntu:24.04:LTS | trafficserver | no fix listed | UBUNTU-CVE-2026-58187 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Traffic Server | 8.0.0 – through 8.1.119.0.0 – through 9.2.1410.0.0 – through 10.1.3 |
Weakness: CWE-787 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
References
- https://lists.apache.org/thread/5prl9glcm9g2swnq9hqxvnokylm1gr6d vendor-advisory