Vulnerability · Published Jun 26, 2026 · Assigned by apache

CVE-2026-57915Apache Kerby: Kerberos Pre-Authentication Bypass

High 7.3

In plain English

A high-severity security flaw in Apache Kerby from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 45% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.3High
Exploit odds (30 days)0.5%top 55.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

It is possible to bypass the Kerberos pre-authentication check in Apache Kerby by sending a PA-DATA with an unrecognized or unsupported type. Users are recommended to upgrade to version 2.1.2, which fixes this issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavenorg.apache.kerby:kerb-server2.1.2GHSA-262p-fj3f-xh7v

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Kerby 0 – before 2.1.2

Weakness: CWE-304, CWE-358 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

References