Vulnerability · Published Jun 26, 2026 · Assigned by apache

CVE-2026-57914Apache Kerby: StackOverflow on parsing deeply nested ASN1 structures

Medium 6.5

In plain English

A medium-severity uncontrolled resource consumption in Apache Kerby from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 38% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.5Medium
Exploit odds (30 days)0.4%top 62.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

By sending a deeply nested ASN1 structure to a Apache Kerby client or service, it's possible to trigger a StackOverFlow Exception which can lead to denial of service issues. Users are recommended to upgrade to version 2.1.2, which fixes this issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavenorg.apache.kerby:kerby-asn12.1.2GHSA-x6vc-x4v4-hjhr

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Kerby 0 – before 2.1.2

Weakness: CWE-400 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

References