Vulnerability · Published Jul 8, 2026 · Assigned by GitHub_M

CVE-2026-57480Parse Server: Denial of service via exponential-time processing of deeply nested query operators

High 8.7

In plain English

A high-severity security flaw in parse-server from parse-community. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 48% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.7High
Exploit odds (30 days)0.6%top 51.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.9.1-alpha.12 and 8.6.82, deeply nested $or, $and, and $nor query condition operators in the REST API or LiveQuery query handling could trigger exponential-time processing in the internal query-traversal helper and block the Node.js event loop. This issue is fixed in versions 9.9.1-alpha.12 and 8.6.82.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmparse-server9.9.1-alpha.12GHSA-cgxm-vr2f-6fj8
npmparse-server8.6.82GHSA-cgxm-vr2f-6fj8

Affected products (as reported)

VendorProductVersions
parse-community parse-server >= 9.0.0-alpha.1, < 9.9.1-alpha.12< 8.6.82

Weakness: CWE-407 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

References