Vulnerability · Published Jun 25, 2026 · Assigned by GitHub_M

CVE-2026-57453Vim: PowerShell Command Injection via Unescaped Filename in zip.vim Extraction

Medium 6.5

In plain English

A medium-severity command injection in vim from vim. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 11% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.5Medium
Exploit odds (30 days)0.2%top 89.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Vim is an open source, command line text editor. From 9.1.1784 until 9.2.0678, when the bundled zip plugin autoload/zip.vim falls back to PowerShell to browse, read, extract, update or delete entries in a zip archive, it builds the PowerShell command by inserting archive entry names that are quoted only for the shell, not for PowerShell. A crafted entry name can break out of the intended string context and cause PowerShell to execute arbitrary commands with the privileges of the user running Vim, triggered by opening, viewing or extracting the archive. This vulnerability is fixed in 9.2.0678.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.23vim9.2.0854-r0ALPINE-CVE-2026-57453
Alpine:v3.24vim9.2.0680-r0ALPINE-CVE-2026-57453
Debian:14vim2:9.2.0782-1DEBIAN-CVE-2026-57453
Ubuntu:22.04:LTSvim2:8.2.3995-1ubuntu2.33USN-8500-1
Ubuntu:24.04:LTSvim2:9.1.0016-1ubuntu7.17USN-8500-1
Ubuntu:25.10vim2:9.1.0967-1ubuntu6.8USN-8500-1
Ubuntu:26.04:LTSvim2:9.1.2141-1ubuntu4.6USN-8500-1
Ubuntu:26.04:LTSvim2:9.1.2141-1ubuntu4.6UBUNTU-CVE-2026-57453

Affected products (as reported)

VendorProductVersions
vim vim >= 9.1.1784, < 9.2.0678

Weakness: CWE-77 · Vector: CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:L

References