Vulnerability · Published Jun 25, 2026 · Assigned by GitHub_M

CVE-2026-57452Vim: Out-of-bounds Read with libsodium-encrypted Files

Medium 5.5

In plain English

A medium-severity out-of-bounds read in vim from vim. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 6% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.5Medium
Exploit odds (30 days)0.2%top 93.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Vim is an open source, command line text editor. Prior to 9.2.0671, when Vim opens a file encrypted with the VimCrypt~04! or VimCrypt~05! method (xchacha20poly1305, requires the +sodium feature) whose body is shorter than a single libsodium secretstream header, an unsigned length calculation underflows and a subsequent decryption call reads far past the end of the input buffer, crashing Vim. This vulnerability is fixed in 9.2.0671.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.23vim9.2.0854-r0ALPINE-CVE-2026-57452
Alpine:v3.24vim9.2.0677-r0ALPINE-CVE-2026-57452
Debian:12vimno fix listedDEBIAN-CVE-2026-57452
Debian:13vim2:9.1.1230-2+deb13u1DEBIAN-CVE-2026-57452
Debian:14vim2:9.2.0782-1DEBIAN-CVE-2026-57452
Ubuntu:22.04:LTSvim2:8.2.3995-1ubuntu2.33UBUNTU-CVE-2026-57452
Ubuntu:22.04:LTSvim2:8.2.3995-1ubuntu2.33USN-8500-1
Ubuntu:24.04:LTSvim2:9.1.0016-1ubuntu7.17USN-8500-1
Ubuntu:24.04:LTSvim2:9.1.0016-1ubuntu7.17UBUNTU-CVE-2026-57452
Ubuntu:25.10vim2:9.1.0967-1ubuntu6.8USN-8500-1
Ubuntu:25.10vim2:9.1.0967-1ubuntu6.8UBUNTU-CVE-2026-57452
Ubuntu:26.04:LTSvim2:9.1.2141-1ubuntu4.6USN-8500-1
Ubuntu:26.04:LTSvim2:9.1.2141-1ubuntu4.6UBUNTU-CVE-2026-57452

Affected products (as reported)

VendorProductVersions
vim vim < 9.2.0671

Weakness: CWE-125, CWE-191 · Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

References