Vulnerability · Published Jun 25, 2026 · Assigned by GitHub_M

CVE-2026-57438Nokogiri: Possible Use-After-Free in XInclude Processing

Low 2.2

In plain English

A low-severity use-after-free in nokogiri from sparklemotion. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.1% (higher than 2% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)2.2Low
Exploit odds (30 days)0.1%top 97.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Nokogiri is an open source XML and HTML library for the Ruby programming language. Prior to 1.19.4, XInclude substitution performed by Nokogiri::XML::Node#do_xinclude replaced each <xi:include> in place, freeing the include node along with its children (such as <xi:fallback> and its descendants) and any namespaces declared on them. If an application had already exposed one of those nodes or namespaces to Ruby, the corresponding Ruby object was left pointing at freed memory. Using the object could result in invalid reads or writes to memory. This vulnerability is fixed in 1.19.4.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12ruby-nokogirino fix listedDEBIAN-CVE-2026-57438
Debian:13ruby-nokogirino fix listedDEBIAN-CVE-2026-57438
Debian:14ruby-nokogiri1.19.4+dfsg-1DEBIAN-CVE-2026-57438
RubyGemsnokogiri1.19.4GHSA-wfpw-mmfh-qq69
Ubuntu:24.04:LTSruby-nokogirino fix listedUBUNTU-CVE-2026-57438
Ubuntu:25.10ruby-nokogirino fix listedUBUNTU-CVE-2026-57438
Ubuntu:26.04:LTSruby-nokogirino fix listedUBUNTU-CVE-2026-57438
Ubuntu:26.10ruby-nokogirino fix listedUBUNTU-CVE-2026-57438

Affected products (as reported)

VendorProductVersions
sparklemotion nokogiri < 1.19.4

Weakness: CWE-416 · Vector: CVSS:4.0/AV:L/AC:H/AT:N/PR:N/UI:N/VC:L/VI:L/VA:H/SC:N/SI:N/SA:N/E:U

References