Vulnerability · Published Jun 25, 2026 · Assigned by GitHub_M

CVE-2026-57436Nokogiri: Possible Use-After-Free when setting `Document#root=` to an invalid node type

Low 1.7

In plain English

A low-severity use-after-free in nokogiri from sparklemotion. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 35% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)1.7Low
Exploit odds (30 days)0.4%top 65.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Nokogiri is an open source XML and HTML library for the Ruby programming language. Prior to 1.19.4, Nokogiri::XML::Document#root= validated only that the new root was a Nokogiri::XML::Node, allowing a DTD node to be set as the document root. The result is a heap use-after-free during garbage collection or finalization, leading to an invalid memory read or potentially a segfault. This vulnerability is fixed in 1.19.4.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12ruby-nokogirino fix listedDEBIAN-CVE-2026-57436
Debian:13ruby-nokogirino fix listedDEBIAN-CVE-2026-57436
Debian:14ruby-nokogiri1.19.4+dfsg-1DEBIAN-CVE-2026-57436
RubyGemsnokogiri1.19.4GHSA-wjv4-x9w8-wm3h
Ubuntu:24.04:LTSruby-nokogirino fix listedUBUNTU-CVE-2026-57436
Ubuntu:25.10ruby-nokogirino fix listedUBUNTU-CVE-2026-57436
Ubuntu:26.04:LTSruby-nokogirino fix listedUBUNTU-CVE-2026-57436
Ubuntu:26.10ruby-nokogirino fix listedUBUNTU-CVE-2026-57436

Affected products (as reported)

VendorProductVersions
sparklemotion nokogiri < 1.19.4

Weakness: CWE-416 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:U

References