Vulnerability · Published Jun 25, 2026 · Assigned by GitHub_M
CVE-2026-57236Nokogiri: Possible Use-After-Free when `Nokogiri::XML::Document#encoding=` raises an exception
Low 1.7
In plain English
A low-severity use-after-free in nokogiri from sparklemotion. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 37% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Nokogiri is an open source XML and HTML library for the Ruby programming language. Prior to 1.19.4, calling Document#encoding= with an invalid encoding (e.g., a non-string, or a string containing a null byte) raises an exception, but only after freeing the document's current encoding string without replacing it. The document is left referencing freed memory, so the next call to Document#encoding reads invalid memory, which can cause a segfault or leak freed bytes into a Ruby String. Affects the CRuby (libxml2) implementation only; JRuby is not affected. This vulnerability is fixed in 1.19.4.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | ruby-nokogiri | no fix listed | DEBIAN-CVE-2026-57236 |
| Debian:13 | ruby-nokogiri | no fix listed | DEBIAN-CVE-2026-57236 |
| Debian:14 | ruby-nokogiri | 1.19.4+dfsg-1 | DEBIAN-CVE-2026-57236 |
| RubyGems | nokogiri | 1.19.4 | GHSA-5v8h-3h3q-446p |
| Ubuntu:24.04:LTS | ruby-nokogiri | no fix listed | UBUNTU-CVE-2026-57236 |
| Ubuntu:25.10 | ruby-nokogiri | no fix listed | UBUNTU-CVE-2026-57236 |
| Ubuntu:26.04:LTS | ruby-nokogiri | no fix listed | UBUNTU-CVE-2026-57236 |
| Ubuntu:26.10 | ruby-nokogiri | no fix listed | UBUNTU-CVE-2026-57236 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| sparklemotion | nokogiri | < 1.19.4 |
Weakness: CWE-416 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:U