Vulnerability · Published Jul 10, 2026 · Assigned by GitHub_M

CVE-2026-57221RabbitMQ: Passive queue/exchange declaration bypasses authorization checks, leaking queue metadata to unprivileged users

Medium 5.3

In plain English

A medium-severity missing authorization in rabbitmq-server from rabbitmq. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 36% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)5.3Medium
Exploit odds (30 days)0.4%top 64.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

RabbitMQ is a messaging and streaming broker. Prior to 3.13.15, 4.0.20, 4.1.11, and 4.2.6, RabbitMQ does not perform authorization checks on passive queue.declare and exchange.declare AMQP 0-9-1 operations, allowing any authenticated user who can connect to a virtual host to enumerate queue and exchange names and read queue message and consumer counts. This issue is fixed in versions 3.13.15, 4.0.20, 4.1.11, and 4.2.6.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12rabbitmq-serverno fix listedDEBIAN-CVE-2026-57221
Debian:13rabbitmq-serverno fix listedDEBIAN-CVE-2026-57221
Debian:14rabbitmq-server4.3.0-2DEBIAN-CVE-2026-57221
Ubuntu:22.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-57221
Ubuntu:24.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-57221
Ubuntu:26.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-57221
Ubuntu:26.10rabbitmq-serverno fix listedUBUNTU-CVE-2026-57221

Affected products (as reported)

VendorProductVersions
rabbitmq rabbitmq-server >= 4.2.0, < 4.2.6>= 4.1.0, < 4.1.11>= 4.0.0, < 4.0.21>= 3.13.0, < 3.13.15

Weakness: CWE-862 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:L/SI:N/SA:N

References