Vulnerability · Published Jul 10, 2026 · Assigned by GitHub_M

CVE-2026-57219RabbitMQ: Unauthenticated disclosure of OAuth client credentials via an HTTP API endpoint with certain less common OAuth 2 configurations

High 8.7

In plain English

A high-severity information exposure in rabbitmq-server from rabbitmq. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.8% (higher than 87% of all known vulnerabilities). Ready-made attack tooling exists: Nuclei. Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.7High
Exploit odds (30 days)2.8%top 13.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Nuclei

Official description

RabbitMQ is a messaging and streaming broker. Prior to 3.13.15, 4.0.20, 4.1.11, and 4.2.6, the obsolete GET /api/auth endpoint can disclose the OAuth 2 client secret on RabbitMQ installations configured with management.oauth_client_secret, exposing credentials to unauthenticated callers when the management plugin and that OAuth configuration are enabled. This issue is fixed in versions 3.13.15, 4.0.20, 4.1.11, and 4.2.6.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12rabbitmq-serverno fix listedDEBIAN-CVE-2026-57219
Debian:13rabbitmq-serverno fix listedDEBIAN-CVE-2026-57219
Debian:14rabbitmq-server4.3.0-2DEBIAN-CVE-2026-57219
Ubuntu:22.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-57219
Ubuntu:24.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-57219
Ubuntu:26.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-57219
Ubuntu:26.10rabbitmq-serverno fix listedUBUNTU-CVE-2026-57219

Affected products (as reported)

VendorProductVersions
rabbitmq rabbitmq-server >= 4.2.0, < 4.2.6>= 4.1.0, < 4.1.11>= 4.0.0, < 4.0.21>= 3.13.0, < 3.13.15

Weakness: CWE-200 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:H/VI:H/VA:N/SC:H/SI:H/SA:N

References