Vulnerability · Published Jul 10, 2026 · Assigned by GitHub_M

CVE-2026-57218RabbitMQ: AMQP 0-9-1 in combination with OAuth 2: consumer persistence can lead to post-revocation message disclosure

Medium 4.9

In plain English

A medium-severity incorrect authorization in rabbitmq-server from rabbitmq. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 29% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)4.9Medium
Exploit odds (30 days)0.4%top 71.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

RabbitMQ is a messaging and streaming broker. Prior to 4.2.6, RabbitMQ AMQP 0-9-1 allows an existing consumer to keep receiving messages after OAuth token expiry or connection.update_secret refresh to reduced scopes because existing consumers are not canceled or reauthorized at delivery time after the channel user state changes. This issue is fixed in version 4.2.6.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:14rabbitmq-server4.3.0-2DEBIAN-CVE-2026-57218
Ubuntu:22.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-57218
Ubuntu:24.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-57218
Ubuntu:26.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-57218
Ubuntu:26.10rabbitmq-serverno fix listedUBUNTU-CVE-2026-57218

Affected products (as reported)

VendorProductVersions
rabbitmq rabbitmq-server >= 4.2.0, < 4.2.6

Weakness: CWE-863 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:N/SA:N

References