Vulnerability · Published Jul 10, 2026 · Assigned by GitHub_M

CVE-2026-57216RabbitMQ: AMQP 1.0, AMQP 0-9-1, Stream Protocol loopback enforcement can lead to remote guest sessions due to listener-address loopback checks

Medium 6.8

In plain English

A medium-severity improper authentication in rabbitmq-server from rabbitmq. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 43% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.8Medium
Exploit odds (30 days)0.5%top 56.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

RabbitMQ is a messaging and streaming broker. Prior to 3.13.15, 4.0.20, 4.1.11, and 4.2.6, AMQP 0-9-1, AMQP 1.0, and Stream Protocol authentication can allow a loopback-restricted user such as guest to connect remotely when traffic is accepted through a trusted PROXY-protocol path and the backend listener is loopback-bound because the loopback check uses the listener-side socket address instead of the real client source. This issue is fixed in versions 3.13.15, 4.0.20, 4.1.11, and 4.2.6.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12rabbitmq-serverno fix listedDEBIAN-CVE-2026-57216
Debian:13rabbitmq-serverno fix listedDEBIAN-CVE-2026-57216
Debian:14rabbitmq-server4.3.0-2DEBIAN-CVE-2026-57216
Ubuntu:22.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-57216
Ubuntu:24.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-57216
Ubuntu:26.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-57216
Ubuntu:26.10rabbitmq-serverno fix listedUBUNTU-CVE-2026-57216

Affected products (as reported)

VendorProductVersions
rabbitmq rabbitmq-server >= 4.2.0, < 4.2.6>= 4.1.0, < 4.1.11>= 4.0.0, < 4.0.21>= 3.13.0, < 3.13.15

Weakness: CWE-287 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:N/A:N

References