Vulnerability · Published Jul 10, 2026 · Assigned by GitHub_M

CVE-2026-57215RabbitMQ: Direct-reply-to binding persistence can lead to unauthorized reply-channel injection and persistent phantom

High 7.0

In plain English

A high-severity incorrect authorization in rabbitmq-server from rabbitmq. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 32% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)7.0High
Exploit odds (30 days)0.4%top 67.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

RabbitMQ is a messaging and streaming broker. Prior to 3.13.15, 4.0.20, 4.1.11, and 4.2.6, RabbitMQ allows foreign bindings to amq.rabbitmq.reply-to destinations because volatile direct-reply-to queues can be accepted at bind and route time but are missing from Khepri-backed deletion checks, leaving persistent route entries after unbind. This issue is fixed in versions 3.13.15, 4.0.20, 4.1.11, and 4.2.6.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12rabbitmq-serverno fix listedDEBIAN-CVE-2026-57215
Debian:13rabbitmq-serverno fix listedDEBIAN-CVE-2026-57215
Debian:14rabbitmq-server4.3.0-2DEBIAN-CVE-2026-57215
Ubuntu:22.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-57215
Ubuntu:24.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-57215
Ubuntu:26.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-57215
Ubuntu:26.10rabbitmq-serverno fix listedUBUNTU-CVE-2026-57215

Affected products (as reported)

VendorProductVersions
rabbitmq rabbitmq-server >= 4.2.0, < 4.2.6>= 4.1.0, < 4.1.11>= 4.0.0, < 4.0.21>= 3.13.0, < 3.13.15

Weakness: CWE-863 · Vector: CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N

References